ModMultiSim help v3.04 - 2.1. Introduction

Download manual: HTML

2.1. Introduction

The main ModMultiSim window contains display areas for Slave Registers and beneath that Environment Properties, and a rectangular area at the bottom, which is the status bar. Above these is a tool bar with the buttons Log, Run Slave Simulation and Serve Masters, each of which can also be found under the Settings menu on the menubar.

The status bar is used for reporting error or warning messages.

On the menu bar, the Settings menu provides access to the main configuration dialog for editing settings via the Edit Settings... menu item. On the File menu there are options to open and save configuration files, to import from and export to a comma-separated (CSV) file, and to exit the program. Aside from that, a View menu provides an option to view logging, and a Help menu has options to access help and product details.

When first setting up ModMultiSim the place to start is from the SettingsEdit Settings... dialog where slaves, their environment, and the master interface can be configured (see Edit Settings...). Once added, registers and environment properties are displayed in the main window in the Slave Registers and Environment Properties area respectively.

If settings (including registers) have already been configured and they need saving, or a configuration file needs opening, then select FileSave Settings... or FileOpen Settings... (sections Save Settings... and Open Settings... ). The save option saves in XML format, and the open option opens a file already saved in XML format. Alternatively, to save settings (slave registers only) to a CSV file, or open a CSV file, select FileExport CSV... or FileImport CSV... (sections Export CSV... and Import CSV... ).